Building Error

Topics: General Topics, SharpMap Project
Apr 24, 2010 at 7:42 PM

Hello,

I'm new at SharpMap group.

 

I've checked out the recent version via SVN.

 

when I've tried to build it, I've got the folowing Errors:

Error 189 'BruTile.TileInfo' does not contain a definition for 'Key' and no extension method 'Key' accepting a first argument of type 'BruTile.TileInfo' could be found (are you missing a using directive or an assembly reference?) D:\Develop\SharpMap\Trunk\SharpMap\Layers\TileLayer.cs 157 38 SharpMap.VS2008
Error 190 'BruTile.TileInfo' does not contain a definition for 'Key' and no extension method 'Key' accepting a first argument of type 'BruTile.TileInfo' could be found (are you missing a using directive or an assembly reference?) D:\Develop\SharpMap\Trunk\SharpMap\Layers\TileLayer.cs 169 42 SharpMap.VS2008
Error 197 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap\bin\Debug\SharpMap.dll' could not be found SharpMap.UI.VS2008
Error 198 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap\bin\Debug\SharpMap.dll' could not be found SharpMap.Extensions.VS2008
Error 199 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap.UI\bin\Debug\SharpMap.UI.dll' could not be found DemoWinForm.VS2008
Error 200 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap\bin\Debug\SharpMap.dll' could not be found DemoWinForm.VS2008
Error 201 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap\bin\Debug\SharpMap.dll' could not be found UnitTests.VS2008
Error 202 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap.Extensions\bin\Debug\SharpMap.Extensions.dll' could not be found UnitTests.VS2008
Error 203 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap\bin\Debug\SharpMap.dll' could not be found ExampleCodeSnippets
Error 204 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap.Extensions\bin\Debug\SharpMap.Extensions.dll' could not be found ExampleCodeSnippets
Error 205 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap\bin\Debug\SharpMap.dll' could not be found WinFormSamples
Error 206 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap.UI\bin\Debug\SharpMap.UI.dll' could not be found WinFormSamples
Error 207 Metadata file 'D:\Develop\SharpMap\Trunk\SharpMap.Extensions\bin\Debug\SharpMap.Extensions.dll' could not be found WinFormSamples

When I checked, I saw that TileInfo doesn't contain 'Key' as a member.

I've have also 196 warnings.

 

Can someone please help me?

Thanks,

Gal.


Apr 24, 2010 at 9:31 PM

Hi Gal,

I believe there may be an issue with Change set 65731? Either revert TileLayer.cs to the previous change set or in TileLayer.cs you will find two references to tileInfo.Key, change those to tileInfo.Index.

Scott

Developer
Apr 25, 2010 at 6:58 AM

hi,

Thanks for reporting. Scottt is right. 

I had renamed to 'Index' in change set 65729, but in change set 65731 it is back to 'Key'. This is odd because there is no change to that file according to the log.

No change to TileLayer.cs:

http://sharpmap.codeplex.com/SourceControl/changeset/changes/65731

Yet, 65731:

http://sharpmap.codeplex.com/SourceControl/changeset/view/65731#1074394

..is different from 65729:

http://sharpmap.codeplex.com/SourceControl/changeset/view/65729#1074394

I just updated the file again. It should be fixed.

Paul

Apr 25, 2010 at 7:49 AM

Hey,

The new version fixed the problem with TileLayer.

 

After rebuild the soultion I've got 1 error:

Error 202 The type or namespace name 'TileSourceOsm' could not be found (are you missing a using directive or an assembly reference?) C:\SharpMap\Trunk\WinFormSamples\Samples\TileLayerSample.cs 18 53 WinFormSamples

In oreder to make it work, I've changed all the related code to be a note (It's a sample so I guessed it's ok).

Now it works, but you might want to check TileSourceOsm error.

 

Thanks.

 
Developer
Apr 25, 2010 at 8:30 AM

hey, you guys are quick to check. Thanks, I had just fixed that one too. My build server says it builds again.

Paul