Web Controls in Sharpmap v2

Topics: SharpMap v2.0, Web Controls
Mar 22, 2011 at 11:26 AM
Edited Mar 22, 2011 at 12:01 PM

Hello!

Using Web Controls in Sharpmap v2 I've faced with follow problem:

not all outputed tiles were shown right (see screenshots):

screenshot1
screenshot2
screenshot3

Can you help me?

Coordinator
Mar 23, 2011 at 11:20 AM

Diego has put some effort into branches/CustomWmsSamples. It seemed to me that he resolved some of your issues.

Hth FObermaier

Developer
Mar 23, 2011 at 1:56 PM

Yes, I've fixed some issues with GdiRendering, but looks like you have also other issue.

In particular, using polymaps as "webmapping" client I've encountered some issue that looks similar to yours, but using openlayers all looks fine.

So you can try to use the branch that I've created and see if it works for you: if not, feel free to send me a sample code, and I try to do my best to take a look.

Mar 23, 2011 at 3:48 PM
Edited Mar 23, 2011 at 3:48 PM

hi,

ego2,contact me by email please. i sent you a message.

Mar 23, 2011 at 5:12 PM

Thanks for all! I'll try it and notice you.

shahin_sharifi, I've got your message. I'll answer you.

Mar 29, 2011 at 8:04 AM
Edited Mar 29, 2011 at 8:04 AM

can I see your sample code?I really want to take a look,thanks

Mar 29, 2011 at 8:57 AM

I can't find branches/CustomWmsSamples,where is it? can you help me? thank you!!!

Apr 1, 2011 at 12:03 PM

Hello, everybody
Thanks a lot for your help. branches/CustomWmsSamples works perfectly.
chensheng9, you can find it at the follow link. Load it via svn.

Apr 8, 2011 at 10:07 AM
Edited Apr 8, 2011 at 10:10 AM

Hello! I've got one more problem.

Default shape file is shown perfect, but my own files doesn't output.

On screenshots: I add my shape-file "RegionsRF" and additional files:

screenshot1
screenshot2

One more thing: web-service shows shape file well, but web-control doesn't.

Any suggestions?

Developer
Apr 9, 2011 at 11:08 AM

check if your data is copied in the bin folder, if not set "copy if newer" in the properties of your files (inside visual studio properties window)