got some compliation error.

Topics: SharpMap v2.0
Apr 14, 2008 at 6:22 PM
I get the latest code, and encounter the following error.

error CS0305: Using the generic type 'GeoAPI.IO.WellKnownText.WktWriter<TCoordinate>' requires '1' type arguments

It seems to me that GeoApi got updated, but the SharpMap is not, which version of GeoApi should I get ?
Apr 14, 2008 at 6:43 PM
Hi Yuren, It looks like you are using GeoAPI from the branches/v2 branch - this goes with the SharpMap v2 code (which is hosted on google code not codeplex and is currently unstable ) use the GeoAPI/trunk and SharpMap/trunk (from codeplex) and you have the latest stable code... hth jd