Start with v0.9 or v2 ?

Topics: SharpMap v0.9 / v1.x, SharpMap v2.0
May 20, 2008 at 2:58 PM
Hi,
I am going to use SharpMap and I would like to know which version should I use ? is the version 2 compatible with 0.9 ?

Thanks for the help !
Coordinator
May 21, 2008 at 6:14 AM
Hi amine_tn -

v0.9 is fairly-well production quality.

v2.0 is not quite. In fact, after Beta 1, it doesn't do much of anything, although that is poised to change very soon, as we drop something that builds and mostly runs.

v2.0 has many of the same concepts as v0.9, but they've been reworked to support new functionality, and so the API is different. The goal, however, was to make the end-developer's life as easy as possible, and to change it as little as needed.

If you feel competent and can accept the risk, go for v2.0. If you are a fairly new developer or can't accept the risk of bleeding edge, stick with v0.9.
May 21, 2008 at 9:57 AM
Hi codekaizen,

Thank you for your answer.
As I am intending to use Sharp Map to display WMS layers for the beginning with basic functions (pan, zoom) , I will try using the version 2. If I didn't be able to do it, I will use the old version then.

Good luck with ShapMap.