Version Conflict?

Topics: SharpMap Project, SharpMap v0.9 / v1.x
Jan 9, 2012 at 1:47 PM

Dear Community,

I'm very new user of Sharpmap and just downloaded the latest recomended versions of the product. (SharpMap-0.9-AnyCPU-trunk-111117 and SharpMap.Extensions-x86-trunk-111117).  I use the Visual Studio 2010 VB / .net framework 4.0 / windows xp platform.

I tried to create a very simple test project, just to display some geometry points on a windows form. My test points are being in a datatable-object. When I tried to set the vectorlayer.datasource property to DataTablePoint provider (wich are defined in the SharpMap.extensions), I had got the following 'studio' design time error:

'The project currently contains references to more than one version of SharpMap, a direct reference to version 0.9.4338.20113 and an indirect reference (through 'SharpMap.Data.Providers.DataTablePoint') to version 0.9.4338.20594. Change the direct reference to use version 0.9.4338.20594 (or higher) of SharpMap.'

The SharpMap.dll(0.9.4338.20113), SharpMap.Extensions.dll(0.9.4338.20595) and SharpMap.UI.dll(0.9.4338.20115) were referenced in my project of course.

Is there existing version 0.9.4338.20594 (or higher) for SharpMap.dll ? or any idea to solve this conflict?

Thanks.

Coordinator
Jan 10, 2012 at 10:53 PM

The best way to avoid this is to compile sharpmap solution yourself

Hth FObermaier

Jan 12, 2012 at 11:42 AM

Thanks, your advise were usefull and efficient.