AccessViolationException OgrProvider.cs

Topics: General Topics, SharpMap Project, SharpMap v0.9 / v1.x, WinForms Controls
Feb 13, 2012 at 5:44 PM
Edited Feb 15, 2012 at 4:50 PM

Hi, I am using Sharp Map in desktop application with .net 4.0 (C#) on windows 7 with FWTools2.4.7. When I use following code in release mode it give me error:

“Attempted to read or write protected memory. This is often an indication that other memory is corrupt.”

 

  Can anyone help identity the problem.

Map _InternalMap = new Map();
Ogr ogrProvider = new Ogr(@"D:\test.dxf", 0);
VectorLayer lay = new VectorLayer("MAP", ogrProvider);

_InternalMap.Layers.Add(lay);
_InternalMap.ZoomToExtents();
mapBox1.Map = _InternalMap;
mapBox1.Refresh();

Feb 15, 2012 at 4:50 PM
Jaudat wrote:

Hi, I am using Sharp Map in desktop application with .net 4.0 (C#) on windows 7 with FWTools2.4.7. When I use following code in release mode it give me error:

“Attempted to read or write protected memory. This is often an indication that other memory is corrupt.”

 

  Can anyone help identity the problem.

Map _InternalMap = new Map();
Ogr ogrProvider = new Ogr(@"D:\test.dxf", 0);
VectorLayer lay = new VectorLayer("MAP", ogrProvider);

_InternalMap.Layers.Add(lay);
_InternalMap.ZoomToExtents();
mapBox1.Map = _InternalMap;
mapBox1.Refresh();

 

Issue resolved.. see link

http://sharpmap.codeplex.com/workitem/32248

Jul 27, 2012 at 8:57 PM

Hi, I am the same problem with my win application - exe crached with same error. Please, help!

Jul 28, 2012 at 11:05 PM

 There seem to be a problem with FW tool version 2.4.7 with sharpmap. You can download 2.4.8 or simply replace attached file ogr_csharp and osr_csharp in you fw tool install folder “FWTools2.4.7\csharp”.  dowload files from following link.

http://sharpmap.codeplex.com/workitem/32248

Jul 30, 2012 at 3:19 AM

hi ,

where to get fwtool 2.4.8 ? I don't find the 2.4.8 version in gdal.org.

Jul 31, 2012 at 9:16 AM
You can use following libraries, it should solve you problem.


On Mon, Jul 30, 2012 at 7:19 AM, cdqrain <notifications@codeplex.com> wrote:

From: cdqrain

hi ,

where to get fwtool 2.4.8 ? I don't find the 2.4.8 version in gdal.org.

Read the full discussion online.

To add a post to this discussion, reply to this email (SharpMap@discussions.codeplex.com)

To start a new discussion for this project, email SharpMap@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com