The parameter data type of UInt32 is invalid

Topics: SharpMap v0.9 / v1.x
May 10, 2012 at 3:38 PM

Hey guys,

I got the latest version of the project from subversion, restored the SQL backup from the project, built the project (which built fine), and tried to run the demo web site.  While most demos worked, the Simple MS SQL Spatial page threw an error:

Exception Details: System.ArgumentException: The parameter data type of UInt32 is invalid.

Source Error: 

Line 579:                {
Line 580:                    cmd.CommandText = FeatureColumns.GetSelectColumnClause(cmd, FeatureColumns.GetGeometryColumn(true), GetSpatialWhere(bbox, cmd));
Line 581:                    using (var dr = cmd.ExecuteReader())
Line 582:                    {
Line 583:                        if (dr.HasRows)


Source File: D:\Development\SharpMap\SharpMap\Data\Providers\Database\SpatialDbProvider.cs    Line: 581 

 

I changed the code around a little bit to set the DBType to Int64 instead of uInt32, and we got past that point, but then I got another error about missing db columns.  It's making me think I'm missing a component and/or an updated version of the database.  Can anyone shed some light on what my problem might be?  Thanks!

-Nathan

Coordinator
May 10, 2012 at 5:36 PM

that provider is work in progress, hope to fix it tonight

FObermaier

May 11, 2012 at 2:38 PM

Thanks for the quick response, I look forward to seeing it.

Thanks for all the work you do on this project too!

Apr 28, 2013 at 4:45 PM
npond please like to know how you found the solution to this problem and if you can pass me
Coordinator
Apr 29, 2013 at 6:06 AM
This is still work in progress.
MSSqlSpatial is deprecated anyhow, the sample db is not SQLServer 2008.
Apr 29, 2013 at 8:37 PM
Fobermaier

Grateful for the responsiveness.
You could show me the latest project for download.

Thank you.