New Provider - Managed SpatiaLite

Topics: Data Access, SharpMap v0.9 / v1.x
Jun 25, 2012 at 8:30 PM


I've added a new Dataprovider to the trunk now that reads spatialite databases without using libspatialite.

This should simplify deployments alot when you do not need to supply the libspatialite, geos etc. libraries. And it should minimize size of dependencies needed.

Some performance-tests I've made shows that the new provider performs similar or better than the one using libspatialite.

It does support POINT,LINE,POLYGON,MULTIPOINT,MULTILINE,MULTIPOLYGON types. It does NOT support the new 2.5d geometries in SpatiaLite3, but it should be no problem adding support for them either. Please let me know if you need them.

For this provider the only dependency i System.Data.SQLite which means that it also should work on Compact Framework.