sharpmap and win 64bit?

Topics: SharpMap v0.9 / v1.x
Editor
Jul 24, 2012 at 3:25 AM
Edited Jul 24, 2012 at 3:36 AM

Hi All!

i'm using  SharpMap and SharpMap.UI,i have compile those against AnyCPU, it running good on windows 32 bit but when running on win 64 bit does bug:

 

Could not load file or assembly 'SharpMap.Extensions,Version=0.9.4394.21220, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Help me!!!!

Editor
Jul 24, 2012 at 9:27 AM

i try set all projects to target x86 platform but it is not working. Help!

Developer
Jul 24, 2012 at 10:33 AM

are you building code from the trunk or from a specific tag/version?

Editor
Jul 25, 2012 at 2:59 AM

yes, i building code from trunk (version sharpmap-97089).

Developer
Jul 25, 2012 at 7:04 AM

I'm in the same situation (Win7+64bit) and everything looks ok to me. So please can you explain better that you code does? 

Are you running your code or sharpmap sample code, like 'WinFormSamples'? Please provide a detailed info so I can try to reproduce the error.

Coordinator
Jul 25, 2012 at 7:16 AM

It looks like some reference to SharpMap.Extensions is missing... do you have the x86 version of System.Data.SQLite available?

Editor
Jul 26, 2012 at 10:42 AM

thanks all, I had fixed.

Developer
Jul 26, 2012 at 2:46 PM
ronaldovn wrote:

thanks all, I had fixed.

how? maybe you can help others experiencing similar to yours

Editor
Jul 27, 2012 at 1:52 AM

I create my project on win 64 bit instead of making it on 32 bit, then set all projects to target x86 platform. it working for me. Thanks.

Aug 27, 2012 at 9:13 PM


Thanks for your answer in previous posts

error Assembly not load SharpMap
Projects worked on Windows 7
Works without error

When we Pablysh website In Windows Server 2008
Facilities

NET 4
Sql Server R 2
C #

Only problem is on Windows Server 2008.
Project should be run on Windows Server 2008.
error> Assembly not load SharpMap
To fix this error, what should we

Coordinator
Aug 28, 2012 at 5:30 AM

Are you using SharpMap.Extensions (with SQLite or similar)?

In that case you need to  check the "Enable 32-bit applications" on the Application Pool in IIS, or compile SharpMap.Extensions as ANYCPU / 64-bit yourself.

Aug 28, 2012 at 10:38 AM

hi petlof

How do I set

64 or 32 project publish web site

Where should we do it.
It takes place only on Vyzhal
Or
Sharp takes place on a map Tghyrany

Coordinator
Aug 28, 2012 at 11:00 AM

If you right-click the project SharpMap.Extensions for example, you can choose target-cpu.

If you use av x86 build, you need to go into the properties of the Application Pool in IIS and set "Enable 32-bit applications" to True.

Aug 28, 2012 at 11:16 AM
Edited Aug 28, 2012 at 11:28 AM

Hi
Maybe this happened to another friend
If the description along with the picture so it helps to control labor
If it let's video or Photo

Coordinator
Aug 28, 2012 at 1:23 PM

Google is your friend:

http://help.webcontrolcenter.com/KB/a1114/how-to-enable-32-bit-application-pool-iis-7-dedicatedvps.aspx

Aug 28, 2012 at 7:00 PM

Hi
Thanks to a friend

fobermaier , petlof

Thanks for the follow-up
The problem was solved

http://help.webcontrolcenter.com/KB/a1114/how-to-enable-32-bit-application-pool-iis-7-dedicatedvps.aspx

Components very good.

Programmer
Mohamad Hoosein Fahkravary