Migrating V0.9 to V1.0. gdal_wrap not found

Topics: General Topics, SharpMap v0.9 / v1.x, WinForms Controls
Apr 16, 2013 at 8:37 PM
Edited Apr 16, 2013 at 8:59 PM
Hi. I download the last sharmap version and migrate all referencies to Geometries without problems. But when i try to load a new GdalRasterLayer, i get this error:
"Unable to load DLL 'gdal_wrap'". The file exists in directory of fwTools and this is configurated on app.config.
The software was working ok before the change.

What can be the problem?

Thanks for your help and sorry for my english

Diego Lopez.-

Sorry, i forgot something..... The files wich i use are TIFF...
Thanks
Coordinator
Apr 17, 2013 at 5:51 AM
If you've only added SharpMap.Extensions project, you have only the native gdal/ogr assemblies. In addition to those, you need the native wrappers.
You can install these use the nuget package manager by typing
install-package GDAL.Native
Hth FObermaier
Apr 17, 2013 at 8:46 PM
Hello, thanks for your response!

i'm instaled GDAL.Native package and the error disappeared. But when i open the form where i use a control with a MapBox, the designer throw a exception with GeoAPI version 1.7.0.0. I add the assembly redirect in appconfig but the error still.
Which can i do?

Thank for your help!

Diego Lopez.
Coordinator
Apr 18, 2013 at 10:00 AM
You need to add binding redirects to your [app|web].config file, like it is done in the WinFormSamples project.
Hth FObermaier