issue in Rc2 ?

Editor
May 6, 2013 at 3:47 PM
In a project I updated the dll to the RC2 version.

Shapefile provider when I open a shapefile send an error saying it can not load version 1.7.0.0 of GeoAPI.

The dll provided with rc2 is version 1.7.1.0 and the error is relative to .prj file.

many thanks.

T
Coordinator
May 6, 2013 at 3:51 PM
Hi, you need to add Assembly Redirect of GeoAPI to your config-file, se release notes
Editor
May 7, 2013 at 8:44 AM
Sorry,

I was writing a web application, but I see that can include the redirection also in web.confing and that works great !
May 23, 2013 at 4:40 PM
Sorry I seem to be having the same problem but I can not fine the release notes on the site or the code download?
Editor
May 23, 2013 at 4:57 PM
As in https://sharpmap.codeplex.com/releases/view/106717


You have simply to add

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="GeoAPI" publicKeyToken="a1a0da7def465678" culture="neutral" />
<bindingRedirect oldVersion="0.0.0.0-1.7.1.0" newVersion="1.7.1.0" />
</dependentAssembly>
</assemblyBinding>
</runtime>

in application config or web config file
May 24, 2013 at 12:52 PM
Sorry just could not see the forest for the trees.