Sharmap.SqlServerSpatialObjects.dll not found

Topics: Algorithms, CompactFramework, Data Access, General Topics, SharpMap Project, SharpMap v0.9 / v1.x, SharpMap v2.0, Web Controls, WinForms Controls
Apr 7, 2011 at 10:36 AM

Hello Everyone,

I need help. I have download the sharpmap-87233, and when i have tried to build this, the compiler show that error: "Metadata file 'E:\pruebas\sharpmap-87233\Trunk\SharpMap.SqlServerSpatialObjects\bin\Debug\SharpMap.SqlServerSpatialObjects.dll' could not be found".

I don´t know what to do to solve this problem.

Thank you very much.

Coordinator
Apr 7, 2011 at 10:54 AM

Please read this:

http://sharpmap.codeplex.com/SourceControl/changeset/view/87233#1501897

Hth FObermaier

Apr 7, 2011 at 10:58 AM

I read this article, and i installes this componente, but it doesn´t solve my problem.

I don´t know what to do.

Thank you

Coordinator
Apr 7, 2011 at 11:25 AM

right click on project, choose add reference and browse in the .net tab for Microsoft.SqlServer.Types.

If it is not there browse for it on your local harddrive(s)

Hth FObermaier

Apr 7, 2011 at 11:39 AM

I have this reference in UnitTest.vS2008 and in SharpMap.SqlServerSpatialObjects.VS2008.

I have tried to build the project and the same error. I don´t know if I need another program o plugin.

Thank you very much

Coordinator
Apr 7, 2011 at 1:55 PM

could you post the contents of SharpMap.SqlServerSpatialObjects.VS2008.cs, please

Apr 7, 2011 at 2:10 PM

SharpMap.SqlServerSpatialObjects.VS2008
Readme.txt
Properties
AssemblyInfo.cs
References
Microsoft.SqlServer.Types
ProjNET
SharpMap.VS2010
System
System.Data
System.Xml
Converters
SqlServer2008SpatialObjects >> SqlGeometryConverter.cs
Geometries
SpatialOperationsEx.cs
SpatialRelationsEx.cs

This only contents.

Coordinator
Apr 7, 2011 at 2:40 PM

sorry, i meant the contents of the project file (SharpMap.SqlServerSpatialObjects.VS2008.csproj)

Apr 7, 2011 at 2:45 PM

<?xml version="1.0" encoding="utf-8"?>
<Project ToolsVersion="3.5" DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
  <PropertyGroup>
    <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
    <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
    <ProductVersion>9.0.30729</ProductVersion>
    <SchemaVersion>2.0</SchemaVersion>
    <ProjectGuid>{6D681045-8EF1-44EA-A19D-C7A63A6D0F76}</ProjectGuid>
    <OutputType>Library</OutputType>
    <AppDesignerFolder>Properties</AppDesignerFolder>
    <RootNamespace>SharpMap</RootNamespace>
    <AssemblyName>SharpMap.SqlServerSpatialObjects</AssemblyName>
    <TargetFrameworkVersion>v2.0</TargetFrameworkVersion>
    <FileAlignment>512</FileAlignment>
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
    <DebugSymbols>true</DebugSymbols>
    <DebugType>full</DebugType>
    <Optimize>false</Optimize>
    <OutputPath>bin\Debug\</OutputPath>
    <DefineConstants>DEBUG;TRACE</DefineConstants>
    <ErrorReport>prompt</ErrorReport>
    <WarningLevel>4</WarningLevel>
  </PropertyGroup>
  <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Release|AnyCPU' ">
    <DebugType>pdbonly</DebugType>
    <Optimize>true</Optimize>
    <OutputPath>bin\Release\</OutputPath>
    <DefineConstants>TRACE</DefineConstants>
    <ErrorReport>prompt</ErrorReport>
    <WarningLevel>4</WarningLevel>
  </PropertyGroup>
  <ItemGroup>
    <Reference Include="Microsoft.SqlServer.Types, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91, processorArchitecture=MSIL">
      <SpecificVersion>False</SpecificVersion>
      <HintPath>C:\Programme\Microsoft SQL Server\100\SDK\Assemblies\Microsoft.SqlServer.Types.dll</HintPath>
    </Reference>
    <Reference Include="ProjNET, Version=1.2.3537.32090, Culture=neutral, PublicKeyToken=a1f5bdcd9c6f5740, processorArchitecture=MSIL">
      <SpecificVersion>False</SpecificVersion>
      <HintPath>..\ExternalReferences\ProjNET.dll</HintPath>
    </Reference>
    <Reference Include="System" />
    <Reference Include="System.Data" />
    <Reference Include="System.Xml" />
  </ItemGroup>
  <ItemGroup>
    <Compile Include="Converters\SqlServer2008SpatialObjects\SqlGeometryConverter.cs" />
    <Compile Include="Geometries\SpatialRelationsEx.cs" />
    <Compile Include="Geometries\SpatialOperationsEx.cs" />
    <Compile Include="Properties\AssemblyInfo.cs" />
  </ItemGroup>
  <ItemGroup>
    <ProjectReference Include="..\SharpMap\SharpMap.VS2010.csproj">
      <Project>{C83777FC-AABB-47D9-911F-D76255D4D541}</Project>
      <Name>SharpMap.VS2010</Name>
    </ProjectReference>
  </ItemGroup>
  <ItemGroup>
    <Content Include="ReadMe.txt" />
  </ItemGroup>
  <Import Project="$(MSBuildToolsPath)\Microsoft.CSharp.targets" />
  <!-- To modify your build process, add your task inside one of the targets below and uncomment it.
       Other similar extension points exist, see Microsoft.Common.targets.
  <Target Name="BeforeBuild">
  </Target>
  <Target Name="AfterBuild">
  </Target>
  -->
</Project>

Coordinator
Apr 7, 2011 at 2:54 PM

Please remove reference to Microsoft.SqlServer.Types and readd the reference.

Hth FObermaier

Apr 7, 2011 at 3:01 PM

and read the reference??

I remove the reference to Microsoft.SqlServer.Types, but the error continues.

Coordinator
Apr 7, 2011 at 4:19 PM

now that it is removed, you should not read it, re-add the reference to Microsoft.SqlServer.Types

Hth FObermaier

Apr 7, 2011 at 4:36 PM

I add the reference again, and i have the same error.
When I open Microsoft Visual Studio, In the solution explorer >> SharpMap.SqlServerSpatialObjects.VS2008 doesn´t appear "SharpMap.SqlServerSpatialObject-VS2008.csproj"

My error can be provocated by this???

I don´t know what happen.

Developer
Apr 7, 2011 at 7:04 PM

try to update the code, I've committed a small fix that maybe can help you, please let me know if it works

Apr 8, 2011 at 8:18 AM

sorry for the delay. I try to update the code with the three last updates and it doesn´t work.

Thank you very much

Developer
Apr 8, 2011 at 10:57 AM
truxky wrote:

I add the reference again, and i have the same error.
When I open Microsoft Visual Studio, In the solution explorer >> SharpMap.SqlServerSpatialObjects.VS2008 doesn´t appear "SharpMap.SqlServerSpatialObject-VS2008.csproj"

My error can be provocated by this???

I don´t know what happen.

you see in the visual studio the project SharpMap.SqlServerSpatialObjects.VS200 as unoladed? 

try to reload and see what happens.

Apr 8, 2011 at 11:28 AM

The project is load but the file "SharpMap.SqlServerSpatialObject-VS2008.csproj" doesn´t appear.

Developer
Apr 8, 2011 at 11:38 AM
truxky wrote:

The project is load but the file "SharpMap.SqlServerSpatialObject-VS2008.csproj" doesn´t appear.

this isn't possible, if you see the project then the file exists: it's normal that inside visual studio you don't see the file SharpMap.SqlServerSpatialObject-VS2008.csproj, but in the folder directory you can find it.

so I'm actually unable to understand what is your problem: please can you copy the error messages from compilation?

Apr 8, 2011 at 11:43 AM

Yes, In the folder I can view the file, but in Solution Explorer it doesn´t appear.

I don´t know what I do but my error change.

The new error is: " The type or namespace name 'SqlServer2008SpatialObjects' does not exist in the namespace 'SharpMap.Converters' (are you missing an assembly reference?)    E:\Pruebas\sharpmap-87233\Trunk\UnitTests\Converters\SqlServer2008.cs"

What happen??

Thank all very much

Developer
Apr 8, 2011 at 12:03 PM

please click with the right mouse button to solution file (Sharpmap.sln) from inside visual studio.

then properties => configuration properties

then check for SqlServer2008SpatialObjects and see if the build checkbox is clicked, of not, click and recompile

Apr 8, 2011 at 12:20 PM

Yes, it is clicked. The configuration is "released"

Developer
Apr 8, 2011 at 12:24 PM

try to unload the unittests project and see if other projects compile

Apr 8, 2011 at 12:37 PM

I can compile the project but when I am going to execute the program, it make me an error

The error said this: "A project with an Output Type of Class Library can not be started directly"

"In order to debug the project and an executable project to the solution with references the library project. Set the executable project at the startup project"

What I do??

Developer
Apr 8, 2011 at 12:46 PM

set the start project to a project called WinFormSamples and retry.