[SOLVED] SRID Problem

Topics: SharpMap v0.9 / v1.x
Apr 26, 2012 at 9:06 AM

I have a PostgreSql 9 DB with geometries. Their SRID is 4326, although actually they are in SK-32 coordinate system.

 

SharpMap created images without problems until i tried to add my own table. 

I made same fields - the_geom(geomery), gid(serial), then took 1 geometry record from old table with st_astext

 

After that i inserted new row in my new table using GeomFromText with SRID = 4326.

 

But when i tried to launch it, it throwed exception: 

ERROR: XX000: Operation on two geometries with different SRIDs

 

ErrorSQL was: SELECT AsBinary("the_geom") AS Geom FROM "public"."Sells" WHERE "the_geom" && box2d('BOX3D(2174393.60158667 491034.650679584,2174573.98275174 491215.031844653)'::box3d)

Why? How can i fix it? 

Developer
Apr 27, 2012 at 7:56 AM

sorry, but looks a problem more related to postgres, have you tried to ask support in a postgis forum?

http://postgis.refractions.net/mailman/listinfo/postgis-users

Coordinator
Apr 27, 2012 at 8:03 AM

How did you add new the table? is the geom-column registred in the geometry_columns table/view?

May 2, 2012 at 9:02 AM

petlof, yep, that was the problem

Editor
May 4, 2013 at 3:09 AM
We can confirm the SRID of our data with the ST_SRID command:
SELECT ST_SRID(geom) FROM nyc_streets LIMIT 1;