how to force CRS=CRS:84 or SRS version 1.1.1?

Dec 16, 2013 at 4:38 PM
using sharpmap 0.9.4085.24515,

How can i force sharpmap to use SRS version 1.1.1
or use CRS=CRS:84?

Need a way to reverse the coordinates,as sharp map force me to use CRS version 1.3 and my maps are not displaying with the way the coordinates need to be formatted for this version.

Thanks in advance.
Dec 16, 2013 at 9:15 PM
Edited Dec 16, 2013 at 9:19 PM
I've updated my sharpmap.dll to the latest version. So i now have the ability to change CRS version but Im getting an error here.
Public Sub AddPoint(ByVal strName As String, ByVal dLat As Double, ByVal dLong As Double)
 Dim pointA As New GeoAPI.Geometries.Coordinate(dLong, dLat)
getting error here -->Dim provider As New SharpMap.Data.Providers.GeometryProvider(pointA) <-- getting error here
    Dim layer As New SharpMap.Layers.VectorLayer(strName, provider)
    Dim selected As Image = Image.FromFile(System.Web.HttpContext.Current.Server.MapPath("~\images") + "\MapPointMarker.gif")

    layer.Style.Symbol = New Bitmap(selected)
    layer.SRID = SPATIAL_REFERENCE_SYSTEM_ID
    layer.Enabled = True
    layer.MinVisible = Double.Epsilon

    ' add them to a collection
    ' NOTE: timing issue - seems the WMS layer needs to be added before any vector layers.
    _colLayers.Add(layer)